git.lirion.de

Of git, get, and gud

summaryrefslogtreecommitdiffstats
path: root/nagios-plugins-contrib-24.20190301~bpo9+1/check_lm_sensors/check_lm_sensors-4.1.1/Makefile.PL
diff options
context:
space:
mode:
authorHarald Pfeiffer <coding _ lirion.de> 2019-04-17 19:07:19 +0200
committerHarald Pfeiffer <coding _ lirion.de> 2019-04-17 19:07:19 +0200
commit1e2387474a449452b78520b9ad96a8b4b5e99722 (patch)
tree836889471eec7d2aac177405068e2a8f1e2b1978 /nagios-plugins-contrib-24.20190301~bpo9+1/check_lm_sensors/check_lm_sensors-4.1.1/Makefile.PL
downloadnagios-plugins-contrib-1e2387474a449452b78520b9ad96a8b4b5e99722.tar.bz2
initial commit of source fetch
Diffstat (limited to 'nagios-plugins-contrib-24.20190301~bpo9+1/check_lm_sensors/check_lm_sensors-4.1.1/Makefile.PL')
-rw-r--r--nagios-plugins-contrib-24.20190301~bpo9+1/check_lm_sensors/check_lm_sensors-4.1.1/Makefile.PL55
1 files changed, 55 insertions, 0 deletions
diff --git a/nagios-plugins-contrib-24.20190301~bpo9+1/check_lm_sensors/check_lm_sensors-4.1.1/Makefile.PL b/nagios-plugins-contrib-24.20190301~bpo9+1/check_lm_sensors/check_lm_sensors-4.1.1/Makefile.PL
new file mode 100644
index 0000000..5ffe903
--- /dev/null
+++ b/nagios-plugins-contrib-24.20190301~bpo9+1/check_lm_sensors/check_lm_sensors-4.1.1/Makefile.PL
@@ -0,0 +1,55 @@
+# Load the Module::Install bundled in ./inc/
+use inc::Module::Install;
+
+##############################################################################
+# Define metadata (we read it from the binary)
+
+name 'check_lm_sensors';
+version_from 'check_lm_sensors';
+perl_version_from 'check_lm_sensors';
+all_from 'check_lm_sensors.pod';
+
+##############################################################################
+# Specific dependencies
+
+include 'version';
+
+my %prereqs = (
+ 'Carp' => 0,
+ 'English' => 0,
+ 'Getopt::Long' => 0,
+ 'List::MoreUtils' => 0,
+ 'version' => 0,
+);
+
+if( eval { require Monitoring::Plugin } ) {
+ $prereqs{'Monitoring::Plugin'} = 0.31;
+}
+else {
+ $prereqs{'Nagios::Plugin'} = 0;
+}
+
+if( eval { require Monitoring::Plugin::Threshold } ) {
+ $prereqs{'Monitoring::Plugin::Threshold'} = 0;
+}
+else {
+ $prereqs{'Nagios::Plugin::Threshold'} = 0;
+}
+
+if( eval { require Monitoring::Plugin::Getopt } ) {
+ $prereqs{'Monitoring::Plugin::Getopt'} = 0;
+}
+else {
+ $prereqs{'Nagios::Plugin::Getopt'} = 0;
+}
+
+install_script 'check_lm_sensors';
+
+auto_install;
+
+WriteMakefile(
+ PREREQ_PM => \%prereqs,
+ INSTALLSCRIPT => '/usr/lib/nagios/plugins/contrib',
+ INSTALLBIN => '/usr/lib/nagios/plugins/contrib',
+ INSTALLSITESCRIPT => '/usr/lib/nagios/plugins/contrib',
+);